• Facebook Twitter Google+ Youtube Vimeo
  • Italiano English
  • [-] Diminuisci la dimensione del testo [+] Aumenta la dimensione del testo
  • Feed RSS 2.0 Feed ATOM 1.0

»

Shader Effector shader shows clones where they should not be

Forum for: Modelling, Texturing, Animation, Composting and the whole general usage of Cinema4D.

Moderatori: natas, Arkimed, visualtricks, cappellaiomatto

  • Advertising

Shader Effector shader shows clones where they should not be

Messaggioda mcindy » dom nov 02, 2014 1:43 pm

Hi forum,

I have the following problem:

For a customer I need to produce a flat world map, made out of small cubes which form the continents. These cubes should than fly in and form the world map. My solution was to generate a mograph grid out of 150x120 cube clones and than use a shader effector with a black and white map of the world. This worked great but the problem is, that the black (or white when inverted) parts of the map (the oceans) also produce cubes. They are very small, but they are there. Is there a trick to have those cubes only in the white parts of the map?

I already tried to make the original cube very small (1x1) and than scale them up in the shader effector. But still the 1x1 cubes are visible in the ocean areas.

Any ideas?
Allegati
World_Map_cubes0075.jpg
mcindy
 
Messaggi: 2
Iscritto il: dom nov 02, 2014 1:38 pm

Re: Shader Effector shader shows clones where they should no

Messaggioda visualtricks » dom nov 02, 2014 2:06 pm

Hi, It's a little hard to tell without seeing your setup, but in general it should work if you enable the Visibility option in the effector (do not use any trasformation):
Schermata 2014-11-02 alle 12.55.39.jpg


Ps.: Please use the attachment form to attach file and images (see the button "Invia Allegato" below the text field), I'll fix it for you this time.
Immagine Immagine
๏_www.visualtricks.it_๏ .:: In another way, from another point of view ::. .:: COMPUTER SAYS NO ::. ↪ Ken Leeeee ↩
Avatar utente
visualtricks
Moderatore
 
Messaggi: 3514
Iscritto il: gio set 23, 2004 5:13 pm
Località: Pistoia

Re: Shader Effector shader shows clones where they should no

Messaggioda mcindy » dom nov 02, 2014 3:29 pm

visualtricks ha scritto:Hi, It's a little hard to tell without seeing your setup, but in general it should work if you enable the Visibility option in the effector (do not use any trasformation):
Schermata 2014-11-02 alle 12.55.39.jpg


Ps.: Please use the attachment form to attach file and images (see the button "Invia Allegato" below the text field), I'll fix it for you this time.


Thanks man, that little thing does the job, just check "visibility" and everything works fine. Thanks again for the fast and kind reply.
mcindy
 
Messaggi: 2
Iscritto il: dom nov 02, 2014 1:38 pm


  • Advertising

Torna a Cinema 4D

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

Powered by DGworld CMS - Copyright ©2005-2018 DGworld