Ray Connector Chaos!

Forum for: Modelling, Texturing, Animation, Composting and the whole general usage of Cinema4D.

Moderators: visualtricks, cappellaiomatto, natas, Arkimed

Post Reply
  • Advertising
cavman255
Posts: 2
Joined: Thu Nov 21, 2019 4:53 pm

Ray Connector Chaos!

Post by cavman255 » Thu Nov 21, 2019 4:55 pm

Hi,

To create the effect shown in the first frame I’ve got an animated character with a matrix of thinking particles joined up using the Ray Connector plug-in. The first frame renders exactly how I want it to, but then everything goes bezerk on the second frame, but not sure why?
I’m quite new to C4D, so it’s probably something simple. Any help would be appreciated.

Thanks!
Running0060.jpg

User avatar
masterzone
Site Admin
Posts: 8717
Joined: Fri Sep 17, 2004 5:34 pm
Location: Verona

Re: Ray Connector Chaos!

Post by masterzone » Fri Nov 22, 2019 8:47 am

Hi Cavman, welcome aboard.
Maybe something goes wrong with Xpresso and the plugin you mentioned on your topic. I don't know this plugin but surely there something wrong on it. Got some errors into the console? you can open the console windows on script menu and look for errors reported. Sometimes this help to know if something is broken into the script or plugin used.

Second tips, are you sure that this plugin is compatible with your C4D release?

cavman255
Posts: 2
Joined: Thu Nov 21, 2019 4:53 pm

Re: Ray Connector Chaos!

Post by cavman255 » Mon Nov 25, 2019 4:24 pm

Hi,

Thanks for your response masterzone! I did check the scripts, but no errors, and yes, the correct plugin version for my C4D.

As I thought, it was actually something simple!
In the plugin controls, there is a checkbox labelled 'Initial'. There's nothing in any of the documentation to explain its use, but I unchecked this and everything now works perfectly. I'm assuming that it connects all rays from their initial positions to the new position of the nodes as they move - not what I wanted, but might be useful in another context.

User avatar
masterzone
Site Admin
Posts: 8717
Joined: Fri Sep 17, 2004 5:34 pm
Location: Verona

Re: Ray Connector Chaos!

Post by masterzone » Mon Nov 25, 2019 5:07 pm

thanks for putting here your experience about Ray Connectos!

  • Advertising
Post Reply