GLB doesn't export animation

Forum for: Modelling, Texturing, Animation, Composting and the whole general usage of Cinema4D.

Moderatori: Arkimed, natas, visualtricks, cappellaiomatto

Rispondi
  • Advertising
nataliya.tsygankova
Messaggi: 1
Iscritto il: mer gen 20, 2021 3:14 pm

GLB doesn't export animation

Messaggio da nataliya.tsygankova »

Hi! I am struggling to export GLB file with animation. Tried different options , including first to export as alembic file, but they didn't work. When I import GLB to blender or to https://gltf-viewer.donmccurdy.com/ it shows just one fame.

I uploaded the c4d project to google drive, maybe somebody can help me out.
https://drive.google.com/drive/folders/ ... sp=sharing

Thank you, Nataliya
Allegati
Screenshot 2023-11-30 095738.png
Avatar utente
masterzone
Site Admin
Messaggi: 10340
Iscritto il: ven set 17, 2004 5:34 pm
Località: Verona

Re: GLB doesn't export animation

Messaggio da masterzone »

Hello! Nataliya welcome here.

I think you need to change your animation workflow otherwise some parameters become incompatible. Usually when you make an animation with joints some issue occurs during export because some joints are not really animated but moved by kinematic tag...
You must bake the animation via timeline and try to export via GLTF directly. (with some special settings too)
If you export your animation to GLTF, you can see only the Christmas tree moving, this because you animated It via keyframes (high compatibility) and not the joint movements (low compatibility).
So try to bake the animation into the timeline and try again :)

here the GLTF exported with baked animation: www.c4dzone.com/clienti/tentacles11_tree.gltf.zip

If you want to learn about, here below you can find a screenshot with bake animation feature from the time line...remember to select ALL parameters into the bake system and also remember to activate into GLFT parameters the "skin and bake animation"...flags
Allegati
gltf.jpg
gltf.jpg (116.07 KiB) Visto 586 volte
bake.jpg
bake.jpg (160.99 KiB) Visto 586 volte
  • Advertising
Rispondi